Server Outage - 500 Errors - May 12

Incident Report for Actionstep Legal Accounting

Postmortem

Post Incident Review — Platform Service Degradation May 12, 2026  

 

Summary 

On May 12, 2026, Legal Accounting experienced a major service degradation that resulted in spinning screens or a message that read: “Error: 500 - Internal Server Error Could not create lock record for queueing." 

Investigation revealed a significant backlog of background queue activity, which we believe to have been the culprit. 

 

No permanent data loss occurred. However, some users may have lost unsaved in-progress work, including prefilled forms or unsaved snapshot data interrupted during the outage window.

Incident Overview 

What Happened 

  • This issue caused elevated response times, login delays, and periods of platform unavailability affecting multiple firms.  

  • Excessive demand on our databases from a high volume of queries as well as repeated login attempts by a third-party integration was primarily to blame. 

  • Some partially entered data may have been lost between 12:55pm and 1:52pm ET, May 12, 2026. 

Root Cause 

  • Database overload due to excessive queries related to login processes and permission checks.  

  • Repeated authentication traffic generated by a third-party integration account. 

Resolution 

  • Identified what processes were causing database overload. 

  • Eliminated outdates and duplicate queue entries that were contributing to the excessive demand on the database. 

  • Restarted affected background to resume normal operation. 

  • Stabilized database performance and reduced platform-wide latency. 

  • We will continue to observe and investigate how this particular third-party integration behaves and how background jobs/processes impact database capacity to prevent this from happening again. 

 

Corrective & Preventative Actions (in progress) 

  • Rebalance tenant workload distribution across database infrastructure.  

  • Increase infrastructure capacity and performance headroom. 

  • Improve monitoring for queue depth, query latency, and authentication anomalies. 

  • Review queue timeout handling and stuck-process recovery mechanisms. 

  • Investigate excessive integration login activity and snapshot maintenance behavior. 

  • Improve session handling to reduce duplicate authentication requests during degraded conditions. 

Our Commitment 

We resolved the issue by 1:52pm, in just under one hour. However, if you were using Legal Accounting during this timeframe, please know that there is a possibility that your partially entered data did not save. If this is the case, please re-enter that data. Rest assured, we have taken measures to prevent this issue from occurring again. Thank you for your patience and we apologize for any inconvenience this caused.

Posted May 18, 2026 - 16:00 EDT

Resolved

The outage affecting the Actionstep Legal Accounting Platform was resolved at 1.55PM Eastern May 12, 2026. Systems are back online and operating normally. We appreciate your patience and understanding while our team worked to restore service.

A full post-mortem will be posted shortly.

We thank you for your patience and apologize for any inconvenience this has caused.

Thanks,
Actionstep Legal Accounting Team
Posted May 12, 2026 - 14:07 EDT

Monitoring

System status has now returned to normal. We are currently monitoring system performance and stability to ensure the platform is fully recovered. We will provide another update once monitoring is complete.

Regards,
Actionstep Legal Accounting Support Team
Posted May 12, 2026 - 13:55 EDT

Identified

Our team has been working to resolve the outage on the Actionstep Legal Accounting Platform. This remains our top priority, and we thank you for your patience. If you require urgent assistance, please submit a ticket here:
https://support.soluno.legal/support/tickets/new

We will continue to provide regular updates until service is fully restored.
Posted May 12, 2026 - 13:20 EDT

Investigating

We are writing to inform that our team is aware of an outage affecting the Actionstep Legal Accounting system that began at 1.15 PM Eastern.

Our team is investigating this as the highest priority and will work to restore the system to full functionality urgently.

We will communicate with you regularly on this status page regarding the progress of this work to ensure you are back online as soon as possible.

Regards,
Actionstep Legal Accounting Support Team
Posted May 12, 2026 - 13:10 EDT
This incident affected: Canada and United States.