Server Outage - 500 Errors - Jul 08 2026

Incident Report for Actionstep Legal Accounting

Resolved

Our Product Team has confirmed that this issue is now resolved. If you're still seeing error messages, please clear your cache, refresh your page, and try again.
Posted Jul 08, 2026 - 21:07 EDT

Investigating

We are writing to inform that our team is aware of an outage affecting the Actionstep Legal Accounting system that began at 8:50 PM Eastern

Our team is investigating this as the highest priority and will work to restore the system to full functionality urgently.

We will communicate with you regularly on this status page regarding the progress of this work to ensure you are back online as soon as possible.
Posted Jul 08, 2026 - 21:01 EDT
This incident affected: Canada and United States.