The earlier issues impacting the platform have now been fully resolved.
These included: 500 errors and delays while generating PDFs during the billing process. General performance slowness across various parts of the platform. Extended loading times and dashboard access issues, including pages getting stuck while loading.
All systems are now operating normally. If you continue to experience any unusual behaviour, please refresh your browser and try again, or contact Support for further assistance.
Posted Nov 30, 2025 - 19:59 EST
Update
The earlier issues impacting the platform have now been fully resolved.
These included: 500 errors and delays while generating PDFs during the billing process. General performance slowness across various parts of the platform. Extended loading times and dashboard access issues, including pages getting stuck while loading.
All systems are now operating normally. If you continue to experience any unusual behaviour, please refresh your browser and try again, or contact Support for further assistance.
Posted Nov 30, 2025 - 19:58 EST
Update
We are aware of ongoing issues affecting the performance and reliability of several parts of our platform. Our Engineering team are actively investigating the root cause and working to restore full functionality as quickly as possible. We understand how disruptive these interruptions can be and sincerely appreciate your patience while we address them.
At this time, you may experience: 1. 500 errors or Significant delays when generating PDFs during the billing process. 2. General performance slowness across the platform. 3. Extended loading times, stuck in loading or an inability to access the dashboard.
Please know that restoring stable performance is our highest priority. We are committed to keeping you informed and will provide updates as soon as more information becomes available. Thank you for your understanding and continued trust as we work to resolve these issues.
Posted Nov 30, 2025 - 18:27 EST
Update
We are aware of ongoing issues affecting the performance and reliability of several parts of our platform. Our Engineering team are actively investigating the root cause and working to restore full functionality as quickly as possible. We understand how disruptive these interruptions can be and sincerely appreciate your patience while we address them.
At this time, you may experience: 1. 500 errors or Significant delays when generating PDFs during the billing process. 2. General performance slowness across the platform. 3. Extended loading times, stuck in loading or an inability to access the dashboard.
Please know that restoring stable performance is our highest priority. We are committed to keeping you informed and will provide updates as soon as more information becomes available. Thank you for your understanding and continued trust as we work to resolve these issues.
Posted Nov 30, 2025 - 16:42 EST
Update
We truly appreciate your patience and for bearing with us while we work through this. We understand this may be impacting your ability to work, and we’re doing everything we can to resolve it quickly. Our engineering team is fully focused on restoring full functionality as soon as possible. We’ll share updates as soon as new information becomes available. Thank you for your understanding—we’re committed to getting everything back to normal without delay.
You may notice: *significant delays or and inability to produce pdfs during the billing process *General slowness *significant delays or an inability loading the dashboard
Posted Nov 30, 2025 - 11:43 EST
Investigating
We are receiving reports of degraded/slow processing of billing related features and dashboards.
We understand this may be disruptive, and we truly appreciate your patience. Our Engineering team remains fully dedicated to resolving the issue and is working to improve performance of all functions. At this stage, we will only send out updates once we have confirmed new information directly from them. This will mean less frequent, but more informative, updates until Monday. We are committed to passing on that new information to you as quickly as possible