The slowness and performance degradation issue has been resolved. All services are now operating within normal performance thresholds. No further impact is expected.
We will continue to monitor the systems performance to ensure stability. We appreciate your patience and understanding while we resolve this issue.
Posted Nov 27, 2025 - 22:38 EST
Update
As of 6:04 PM EST, we have received reports of slowness, performance degradation and systems crashing.
Our Engineering team are still investigating the root cause of this slowness and performance degradation. They are currently troubleshooting potential causes and we will provide updates as more information becomes available.
We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 27, 2025 - 19:37 EST
Investigating
As of 6:04 PM EST, we have received reports of slowness and systems crashing. Our Engineering team is currently investigating the cause of this slowness and performance degradation.