Monitoring of the current situation has indicated a positive outcome/response. Any one continue to experience issues with the platform can reach out to us at support@soluno.legal and we will work those issues as reported.
Posted Dec 02, 2025 - 17:29 EST
Update
Resolved
Posted Dec 02, 2025 - 17:28 EST
Monitoring
Our team implemented a deployment and restarted the servers, those are now back up and there should be a notable improvement in performance.
If you continue to experience issues, please send an email to support@soluno.legal
We will continue to monitor the current performance.
Posted Dec 02, 2025 - 16:35 EST
Investigating
The engineering team is deploying an update, which will complete within 30 mins. Users may experience errors during this time. This update is to remedy reports of the following, found during monitoring:
Overall system slowness Slow billing Unresponsive Error Messages Queuing Errors - invoices are not loading to review charges, cant issue cheques, overall PDF issues