As of 2:08 AM EST, November 29, 2025 all systems and functions were restored and are operating within normal performance thresholds. No further impact is expected.
We will continue to monitor the systems performance to ensure stability. We appreciate your patience and understanding as the team resolved this issue.
Posted Nov 29, 2025 - 02:31 EST
Update
We understand this outage is disruptive, and we truly appreciate your patience. Our Engineering team remains fully dedicated to resolving the issue and is working nonstop to get all functions up and running. At this stage, we will only send out updates once we have confirmed new information directly from them. This will mean less frequent, but more meaningful, updates until Monday. We are committed to passing on that new information to you as quickly as possible
Posted Nov 28, 2025 - 20:00 EST
Update
We truly appreciate your patience and for bearing with us while we work through this. We understand this may be impacting your ability to work, and we’re doing everything we can to resolve it quickly. Our engineering team is fully focused on restoring full functionality as soon as possible. We’ll share updates as soon as new information becomes available. Thank you for your understanding—we’re committed to getting everything back to normal without delay.
You may notice: *Error 500 messages *General slowness *Difficulty completing or posting transactions
Posted Nov 28, 2025 - 18:38 EST
Update
Our engineering team continues to work tirelessly to resolve the issue and restore full functionality as quickly as possible. We’ll share updates as soon as new information becomes available. Thank you for your patience and understanding—we’re committed to getting performance back to normal operations without delay.
Posted Nov 28, 2025 - 17:39 EST
Update
Our engineering team is working tirelessly to resolve the issue and restore full functionality as quickly as possible. We’ll share updates as soon as new information becomes available. Thank you for your patience and understanding—we’re committed to getting performance back to normal operations without delay.
Posted Nov 28, 2025 - 16:35 EST
Update
Our engineering team is actively working on the Legal Accounting platform to resolve the current issues. At this time, several functions remain unavailable as we work through the restoration process. We truly appreciate your patience and understanding while we continue efforts to bring the platform back to full functionality.
Posted Nov 28, 2025 - 16:21 EST
Update
The engineering team continues to work on the Legal Accounting platform. At this time many functions remain unavailable as they work through the issues.
We appreciate your patience while we continue to work on full restoration
Posted Nov 28, 2025 - 16:06 EST
Update
Our engineering team is actively working on the Legal Accounting platform to resolve the current issues. At this time, several functions remain unavailable as we work through the restoration process. We truly appreciate your patience and understanding while we continue efforts to bring the platform back to full functionality.
Posted Nov 28, 2025 - 15:50 EST
Update
Our engineering team is working tirelessly to resolve the issue and restore full functionality as quickly as possible. We’ll share updates as soon as new information becomes available. Thank you for your patience and understanding—we’re committed to getting performance back to normal operations without delay.
Posted Nov 28, 2025 - 15:37 EST
Update
The engineering team continues to work on the Legal Accounting platform. At this time many functions remain unavailable as they work through the issues.
We appreciate your patience while we continue to work on full restoration
Posted Nov 28, 2025 - 15:22 EST
Update
All Actionstep Legal Accounting platforms remain shut down as the engineering team continues to work on investigating this outage. We will continue to share any information as it becomes available. We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 15:06 EST
Update
All Actionstep Legal Accounting platforms remain shut down as the engineering team continues to work on investigating this outage. We will continue to share any information as it becomes available. We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 14:46 EST
Update
All Actionstep Legal Accounting platforms remain shut down as the engineering team continues to work on investigating this outage. We will continue to share any information as it becomes available. We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 14:29 EST
Update
All Actionstep Legal Accounting platforms remain shut down as the engineering team continues to work on investigating this outage. We will continue to share any information as it becomes available. We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 14:15 EST
Update
To further the investigation and continue focused troubleshooting, all Actionstep Legal Accounting platforms will be shut down for approximately 30 mins. We will continue to share any information as it becomes available. We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 13:58 EST
Update
To focus on resolving this as quickly as possible, Live Chat Support is temporarily offline. Our engineering teams are troubleshooting potential causes and working toward a full resolution.
We will share updates as soon as more information becomes available.
If you have an unrelated question or issue, please email support@soluno.legal, and we’ll assist you as soon as possible.
Thank you for your patience while we work to restore normal performance.
Posted Nov 28, 2025 - 13:40 EST
Update
We are continuing to investigate reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal use
Posted Nov 28, 2025 - 13:22 EST
Update
We are continuing to investigate reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal use
Posted Nov 28, 2025 - 13:06 EST
Update
We are continuing to investigate reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal use
Posted Nov 28, 2025 - 12:49 EST
Update
We are continuing to investigate reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal use
Posted Nov 28, 2025 - 12:31 EST
Update
We are continuing to investigate reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal use
Posted Nov 28, 2025 - 12:14 EST
Update
We have received reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 11:48 EST
Update
As of 10:00am EST, we have received reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 11:33 EST
Update
As of 10:00am EST, we have received reports of slowness, performance degradation and systems crashing.
Live chat support is temporarily offline while we investigate and work to resolve this as quickly as possible. The engineering teams are currently troubleshooting potential causes and we will provide updates as more information becomes available.
If you have an unrelated question or issue, email support@soluno.legal and we will assist as soon as possible.
We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 11:17 EST
Update
As of 10:00am EST, we have received reports of slowness, performance degradation and systems crashing. Our Engineering team are still investigating the root cause of this slowness and performance degradation. They are currently troubleshooting potential causes and we will provide updates as more information becomes available. We appreciate your patience while we work on restoring the performance back to normal.
Posted Nov 28, 2025 - 11:02 EST
Investigating
The development team is investigating reports of degraded server performance, affecting all functions and features.