Server Degradation - Error 500 - Jan 9, 2026

Incident Report for Actionstep Legal Accounting

Resolved

This has now been resolved. If you continue to experience issues with error 500s, please email support@soluno.legal

Thank you - we appreciate your patience.
Posted Jan 09, 2026 - 11:58 EST

Monitoring

At 11:40 AM EST - our engineering team was able to resolve the performance issues and this should be resolved now. We are currently monitoring the situation.

If you continue to experience issues please email as us support@soluno.legal
Posted Jan 09, 2026 - 11:46 EST

Identified

Our team has identified the issue and is currently working to resolve it. Customers should notice a significant improvement.
Posted Jan 09, 2026 - 11:39 EST

Update

We are continuing to investigate this issue.
Posted Jan 09, 2026 - 11:27 EST

Investigating

At 11:00 AM EST, our team became aware of issues effecting servers. The issues present themselves as Error 500 and are across various modules including Billing, Contacts, Reports. Our engineering team is aware and is investigating the issue.

We will continue to update this status page regularly.
Posted Jan 09, 2026 - 11:22 EST
This incident affected: Canada and United States.